Anydesk not working anymore (firewall?)

Hello there,

I was using my virtual machine frequently to connect to my home Network via anydesk.
This was working roughly until yesterday at about 1 PM CEST.

I also don’t have an ID shown for the webminal machine. There is only a ‘0’.
According to the FAQ from anydesk, this could point to the Firewall not allowing anydesk to connect to their servers.

Doea anyone have the same issues? I am not aware changing the Firewall on my system.

Best regards,

I can connect to my home network using my phone. So there doesn’t seem to be an issue on that site.

Hi Mike,

hmm, We are not quite sure. We didn’t update any firewall rules in recent times. If it was working few days back, then there is some other issue not related to webminal root desktop platform.

May be try again sometime later?

Hello laks,

thank you for checking the firewall. That’s quite odd.
I also don’t see any issues with the anydesk network.

Maybe the data center, where webminal root desktop platform has changed something in their policies?
Just a guess.

Can you do me a favor though and try anydesk on another machine?
Maybe some of the other users?


Hi Mike,

Yes, that’s a good idea. Let me try anydesk from my environment and update you whether it worked or not.

Hi Laks,

thanks for testing. I am really looking forward for the results.

Keep in mind that you don’t habve to Setup a Connection.
Just install Anydesk and see if your System gets a address or if the error message "Could not connect to the Anydesk Network (result_unknown) appears on the bottom of the window.


hmm… How did you install anydesk ? I tried using it via .deb and it reports quite lot of missing dependencies.

Let me share my temporary environment credentials with you. Will send the details via DM, I hope you can verify it yourself.

Hi Laks,

thanks at first for the opportunity to use your environment. It was a big help.
I am putting the results here in public, for sharing it with the other users.

The broken depencies could be solved, by typing “apt --fix-broken install”.
This command is also mentioned by the error messages.

After that is was working correctly on your system.
So apparently no general firewall issues.

The problem apparently was that the Anydesk daemon (service) was already working on my machine when I have tried to start the program.
The unintentional reboot of the system solved the issue (thanks again).

Checking the manual of Anydesk (RTFM! :slight_smile: ) confirmed, that this service is running every time in the background.

To solve this issue the solution would have been to just stop the service by typing “systemctl stop anydesk.service”.

Thank you very much for your support.

Best regards,

1 Like

The broken depencies could be solved, by typing “apt --fix-broken install”.

Ah, right. I didn’t try that for anydesk installation.

Thanks Mike for resolving your issue :slight_smile: and posting the details as reference for future users :+1: