Error permission denied

I don’t have permission to go to my home directory
not even to make a directory change or list anything at all

Did you run chmod recently? Your home directory permission messed-up. I fixed it now, please check.

Yes it works correctly! U are fast attending to the possible issues of the platform, thanks!

1 Like

Hello ,

Same issue i am facing.

Getting permission denied with all command.

Please share your username along with a screenshot of this issue. We will check.

Hello, I have the same problem. I ran chmod recently and I think I screw my home directory permission. how can I fix it?

@clau, What is the command and its output? I can see your home directory with proper permssion.
Let us know the details.

for example when i’m doing the lesson 3, if I write “cp -v hello.txt dir2” I receive the following message
“cp: cannot stat ‘dir2/hello.txt’: Permission denied” and with many other commands I receive the same message of “Permission denied”

my home is claudiamella


1 Like

There is no issue with your home directory itself (/home/claudiamella).

The issue is related to dir2.

$ ls -ld /home/claudiamella/dir2
drw-r–r--. 3 claudiamella claudiamella 17 Sep 3 06:21 /home/claudiamella/dir2

Try modifying dir2 permission like “chmod +x dir2” . With directories, x permission stands for search.
Then copy the files.

i dont have permission to home directory
pls help
user id-KirA24

ls -ltrd /home/KirA24
drwx------. 8 KirA24 KirA24 4096 Dec  8 06:33 /home/KirA24

It looks fine. can you share the command along with output/error?

Hi Laks,
Hope you are doing well. I am also facing the same issue.
Not able to run any script, to troubleshoot I wrote very simple script and gave full permissions to it and also to the home directory but still not able to execute the script.
Attaching the error screenshot.

Request you to kindly check and help to solve this issue.

Thank you.

I’m facing issues in getting the out due to crash

I’m facing issues in getting the out due to crash

I’m facing issues in getting the out due to crash

If you face issues with wmsudo please run "pkill -u " then re-run the wmsudo command again. thanks