Missing home directory

On login

139-162-5-218 login: Baggypants                  
Password:                                        
Last login: Wed Apr 20 12:59:52 from localhost, 8
2.29.11.121                                      
login -- Baggypants: /home/Baggypants: change dir
ectory failed: No such file or directory         
Logging in with home = "/".                      
-sh-4.2$                                         
-sh-4.2$ ls -ld /home/Bag*                       
drwx------. 2 Bagas          Bagas           108 
Jul  2  2017 /home/Bagas
drwx------. 4 Bagas22        Bagas22         177 
Jun 16  2021 /home/Bagas22
drwx------. 2 Bagdi          Bagdi           136 
Sep 22  2021 /home/Bagdi
drwx------. 2 Bageta12       Bageta12        108 
Jun  2  2017 /home/Bageta12
drwx------. 3 Baghiu         Baghiu          172 
Sep  5  2017 /home/Baghiu
drwx------. 2 BagietaT       BagietaT        108 
Apr  6 10:58 /home/BagietaT
drwx------. 8 BagleyBryan251 BagleyBryan251 4096 
Feb  9  2017 /home/BagleyBryan251
drwx------. 4 Bago1          Bago1           198 
Nov  3  2017 /home/Bago1
drwx------. 3 Bagrat         Bagrat          151 
Dec  4  2017 /home/Bagrat

Can you confirm your email address ?

The email address on the account? I’m not pasting it here.

Yes, Its there but its starts with “Junk” I want to confirm whether its valid id or some temp. id? Write to us efgadmin AT webminal DOT org for validation from your email. Password details will shared on that email. Also was this account created in 2019? Did you tried some rm -rf recently?

Thanks, I’ve sent an email.

The /home/ directory should be read only for my user though so I shouldn’t have been able to remove it that way.

Thanks for the confirmation. We received your email. I’m not quite sure why your home directory went missing. I don’t think I can recover your home dir data but I can create new home empty directory, will that work for you?

Yes, that would be absolutly fine.

I’m having the same problem. My home directory is missing and I’m getting an our of memory command when I am doing something as simple as creating a directory.

Can you recreate my home directory as well. There is ‘nothing’ there that I want to save so you can create an empty new one for me as well.
Webinal 022-04-25 22.41.06

Can you check now and tell me whether it works now or not.

1 Like

@TG0000 , I replied to your email.

It’s working. Thank you so much for your quick reply !
Whatever you did fixed both my home directory, and it linked my account to the forum here :slight_smile:

It’s working for me now.

Would you also be able to set the login shell to bash? it appears to be missing from my passwd entry

-sh-4.2$ getent passwd Baggypants     
Baggypants:x:176442:176501::/home/Baggypants:   

I thought that I replied to this a couple of days ago. In any case thank you so much. It is working perfectly now.

Thanks for the confirmation @TG0000 Glad to know it works.

@Baggypants Can you try again, it should work now.