Webminal Root Feature: How to connect with SSH from Win10 cmd to my webminal?

Hi there!
I would like to connect with SSH from my Windows 10 to webminal. I have done:
ssh root@ip_adress

but my win 10 wrote:
ssh: connect to host Ip_adress port 22: Connection timed out

Ip adress i took with that command:
ip addr show

But when i tried:
ssh my_login_from_webminal@webminal.com

i saw that i had to type the password. I thought, that password would have been from my webminal account, but i was wrong.

Help me please, because i am newbie in IT and i would like to solve this problem. Moreover, i think that i don’t understand where to see the correct login@server_adress from my webminal.

I am able to provide screenshots, if it needs.

Let me enable the access for your account and provide the ssh details (like port number) in few hours. thanks

root@95f0b2e3ada5:/# ip addr show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
3: eth0@if4: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default 
    link/ether 02:42:ac:11:00:02 brd ff:ff:ff:ff:ff:ff link-netnsid 0
    inet brd scope global eth0

Am i right that user = root and IP= ?

I have just tried acces from my mac and again:

192:~ pavelzelenin$ ssh root@
ssh: connect to host port 22: Operation timed out

Our network environment little complex (you will be accessing it like ssh -p <port-num> root@webminal.com) We may need to reset the environment. Can you backup any critical data from your environment?

I have understood my mistake.
I tried to connect with local IP.

Then i found external IP:

root@95f0b2e3ada5:/# curl ifconfig.io

Created test user:

root@95f0b2e3ada5:/# useradd test
root@95f0b2e3ada5:/# cat etc/passwd
list:x:38:38:Mailing List Manager:/var/list:/usr/sbin/nologin
gnats:x:41:41:Gnats Bug-Reporting System (admin):/var/lib/gnats:/usr/sbin/nologin

To be continued in the next post…

Then i tried to connect and got this:


So i was able to connect, but it needed password. But as you can see i created user without any passwords. May be it will help you.

I havent got any important files, so you could reset the env. Thanks

Okay sure, will update your environment and let you know.

1 Like

Please check your message for details on ssh login.

If everything works well, if possible please share screenshot terminal connected via windows :slight_smile: I never used windows in recent times to login to webminal :stuck_out_tongue:

Hi :slightly_smiling_face:

That’s how it is working on Windows10:

Thank you for help!

1 Like